PDA

View Full Version : Flash Font Woes


ast3r3x
2005-11-22, 13:02
So I've decided to make use of flash on my website. However I've run into the problem of when I publish it...there is no text. This is a problem because it's my navigation menu. Now I am under the impression that static text fields don't require any special font embedding of any sort to get them to show up.

Here (http://www.swigg.net/files/nav_guide.zip) is my flash file if any of you want to take a look. It is Flash 8 though, so you might not be able to open it with previous versions. I'm using Myriad Pro & Myriad Pro Semibold...but I tried doing text with Geneva and that didn't work either.

Any ideas?

dviant
2005-11-22, 15:25
Don't have Flash 8... can it back save to MX 2004? If so I'd take a look at it for you. First thing I'd do is double check to make sure it is indeed a static text box and not dynamic.

drewprops
2005-11-22, 22:16
Same thing here, love to help but I'm on MX2004.

ast3r3x
2005-11-22, 23:16
Ok, MX2004 version is now up (http://www.swigg.net/files/nav_guide.fla)

Thanks for taking a look =)

drewprops
2005-11-22, 23:46
Admittedly, I haven't played with Actionscript too much yet because I've been working toward dynamically generated XHTML w/ CSS styling... using Flash for animations only.

However, I opened your file and immediately changed the first two menu items to a really ugly typeface called 'Advert Regular' then published it with no problems....

http://drewprops.com/applenova/nav_guide.html

Note that the third item (the 'Photos' item) did not publish... looking at that now.

ast3r3x
2005-11-23, 00:00
Admittedly, I haven't played with Actionscript too much yet because I've been working toward dynamically generated XHTML w/ CSS styling... using Flash for animations only.

However, I opened your file and immediately changed the first two menu items to a really ugly typeface called 'Advert Regular' then published it with no problems....

http://drewprops.com/applenova/nav_guide.html

Note that the third item (the 'Photos' item) did not publish... looking at that now.
However the text does appear now when I click on the photos (orange) button. The other two aren't supposed to expand like that in case you were wondering.

Yeah I haven't played with actionscript a lot, I used it a little to make that do what I wanted with some experimentation. I am hoping it doesn't look too ugly, maybe a more traditional menu would look better?

I am curious why you changing the font would work for you but not for me. I'll have to try another font or two and see what's up.

drewprops
2005-11-23, 00:02
In your movieclip named "nav_photos" it begins to work better when you move layer 4 above the other layers... at least the word "photos" is always visible. It's not that the layers aren't working, it's that they're obscured.

Next, moving Layer 3 up to where it's under Layer 4 brings those items into view. It looks like you've mixed some animation and actionscript on one layer, which seems to be something that the books I'm reading suggest you do not do. They suggest putting your actionscripts into their own layer.

Anyway, here's the new version....

http://drewprops.com/applenova/nav_guide_02.html

and the zipped file:

http://drewprops.com/applenova/nav_guide_02.fla.zip


by the way, I'm not a SMART coder... I'm a whittler. I do a little and test it, do a little and test it. Very slow and very stupid but I finally figure things out this way.

I've reloaded my own web pages 1.5 bazillion times just to see how CSS changes are working. Very slow, very stupid.

ast3r3x
2005-11-23, 00:05
I wonder why it shows differently in flash then it does in the browser...doesn't it use the same player?

Thanks though I'll change your file back to my fonts and see if it works. That would be awesome :)

ast3r3x
2005-11-26, 18:16
I'm sorry, what is the difference between our two movies? As far as I can tell the code is the same, and the layers in nav_photos are in the same order. Yet yours shows up and mine does not.

While I have your attention, is there a way to tell nav_photos to collapse if the person takes their mouse out of the flash document?

drewprops
2005-11-27, 01:47
Oy, I've already tossed the files I first used as I've been spending the long Thanksgiving Day weekend to rebuild my machine with Tiger-y goodness and CS2 freshness. When I do get everything back up and running I can take a look HOWEVER, I do recall that the only thing that I really changed was the order of the layers in the main file, not the movieclip. The artwork from one layer was hiding the artwork from the layers below it.

Go back and see if that's where I changed the stacking level of the layers 'cause I know that I did that somewhere!!

ast3r3x
2005-11-27, 09:06
The levels are in the same order as far as I can tell. Maybe if you changed the arrangement of some of the items on a specific layer, but I don't really know how to tell that anyways. This is very frustrating, maybe I'd have better luck in Flash MX...except the text in 8 looks like normal computer text should, which is the reason I've been wanting to use it.