View Single Post
turtle
Lord of the Rant.
Formerly turtle2472
 
Join Date: Mar 2005
Location: Upstate South Carolina
 
2021-04-12, 10:34

We are back! I tried the restore again today and we are back to the exact point where I shutdown the server and completed a full backup. Please log in and check anything you want to be sure but I'm confident all is well.

What actually happened you might be wondering? Well, I wanted to access the 2TB of SSD storage internally to the Mac mini. This meant I needed to downgrade from ESXi v7U1 to v6.7U2. The problem wasn't the downgrade of the host (which did get me access to the internal storage) but rather than the VMs were at VMware compatibility level v7U1. VMware compatibility is specifically not able to be downgraded. So when restoring you can, in many case, create a new VM and just attach the VMDK (virtual HDDs) from the original machine to the new VM. Some things break when this happens but can easily be corrected.

In my case I had two CentOS 7 VMs that couldn't read the drives. They knew they were CentOS 7, but couldn't access the data beyond EFI. My Windows 2019 Servers all failed to activate and wouldn't let me move my license so I could reactivate them. This left me with $$$ to buy new licenses or get it back the way it was. Given I had clean, good backups I just couldn't pay for the licenses again.

So last night I reinstalled ESXi v7.0b. Notice it isn't U1? Yeah, so I didn't last night in my frustration and kept trying to get the VMs to work. The same ones that wouldn't work before still wouldn't work. So I posted here and walked away. Had some wine with my wife and tried to relax.

Then I realizes I was not at the same version level I was when I took the backups and that the VMware compatibility version must be the issue AGAIN. So this morning I upgraded to the latest and brought the server back to v7U1. Everything is restoring exactly as expected now. As I'm restoring these VMs, I'm noticing that the compatibility level isn't just v7 but is v7U1! Talk about painting myself into a corner.

In the end we have a 10Gb connection from the NAS to my switch and 10Gb from the mini to the switch. So data transfers will be improved either way. I would rather have access to the onboard storage, but not over have running VMs. I don't want to rebuild these things again. Especially when some would require more money to MS and others I literally just built and sunk hours into getting configured the way I needed.

Louis L'Amour, “To make democracy work, we must be a notion of participants, not simply observers. One who does not vote has no right to complain.”
MineCraft? mc.applenova.com | Visit us! | Maybe someday I'll proof read, until then deal with it.
  quote