Thread: USB Hub
View Single Post
Join Date: Jul 2004
2005-02-02, 22:39

Okay. I have a Belkin USB 1.1 hub. This has the ability to have 5 USBs and has the ability to draw it's own power from the outlet.

It worked the way it should when I had my G3. A little over a year ago, I bought a G5. After getting everything connected with the new machine and so fourth, I realized that the hub doesn't work correctly. Well, there are a lot more USB ports on the G5 than there were on my G3 that I didn't bother. Now, I am getting more things that I would like to have another set of ports.

For instance, I cannot plug my game pad into it, which is also a USB 1.1 without a dialogue box with a stop sign icon coming on the screen saying LOW POWER. This has to be connected to a wall, blah blah blah.... well, the power light on the hub is on, so it's getting the power directly from the wall. I have plugged my Sony camera into it with the USB that it came with, and it reads the memory stick great, and iPhoto came up great. So, I thought maybe it was just the game pad. So, today I bought a card reader which would help me out - do't have to hook up the camera all the time - and the damn stop dialogue box came up again, saying LOW POWER! The damn thing!? I don't know what to do. There is not one port taken up, I know that it is directly getting power from the wall.

The only thing I can think of is that maybe the USB hub needs to be 2.0 and not 1.1 - or that there is some type of download (firmware?) that I don't have?

It worked perfectly with my old G3, doesn't work with the G5...

Anyone else know of a similiar problem that they have heard of or run across?

Thanks in advance.