User Name
Password
AppleNova Forums » Apple Products »

x1900xt has had it


Register Members List Calendar Search FAQ Posting Guidelines
x1900xt has had it
Thread Tools
MacFan311
Member
 
Join Date: Aug 2006
 
2007-11-04, 18:45

my x1900xt in my mac pro was giving me issues that i noticed once installed leopard such as pixel artifacts and screen freezing. I installed windows to see if it was leopard or the card and ive come to the conclusion that it is the card. in windows my screen will just go blank and then eventually come back over and over. before i installed leopard tiger was being slow and the screen would lock up but there were no artifacts so i didnt think it was a gfx card problem. the problem is im pretty certain my warranty just ended as i got my computer in october of last year. Anyone had any luck in getting apple to replace bad parts right after the warranty has expired?
  quote
PB PM
Sneaky Punk
 
Join Date: Oct 2005
Location: Vancouver, BC
Send a message via Skype™ to PB PM 
2007-11-04, 19:58

If you do not have extended (3 year) Applecare, looks like you will be buying a new card.
  quote
Dave
Ninja Editor
 
Join Date: May 2004
Location: Bay Area, CA
 
2007-11-05, 02:42

It'd probably be worth talking to them about it though. They might help you out, especially if you can convince them that the problem started before your warranty expired.
  quote
Posting Rules Navigation
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Post Reply

Forum Jump
Thread Tools
Similar Threads
Thread Thread Starter Forum Replies Last Post
GPUs AtlantaX Purchasing Advice 5 2006-11-11 02:33


« Previous Thread | Next Thread »

All times are GMT -5. The time now is 07:53.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©2004 - 2021, AppleNova